OS Command Injection Affecting podman package, versions *


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.61% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-PODMAN-16088481
  • published16 Apr 2026
  • disclosed14 Apr 2026

Introduced: 14 Apr 2026

CVE-2026-33414  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

There is no fixed version for Debian:13 podman.

NVD Description

Note: Versions mentioned in the description apply only to the upstream podman package and not the podman package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Podman is a tool for managing OCI containers and pods. Versions 4.8.0 through 5.8.1 contain a command injection vulnerability in the HyperV machine backend in pkg/machine/hyperv/stubber.go, where the VM image path is inserted into a PowerShell double-quoted string without sanitization, allowing $() subexpression injection. Because PowerShell evaluates subexpressions inside double-quoted strings before executing the outer command, an attacker who can control the VM image path through a crafted machine name or image directory can execute arbitrary PowerShell commands with the privileges of the Podman process. On typical Windows installations this means SYSTEM-level code execution, and only Windows is affected as the code is exclusive to the HyperV backend. This issue has been patched in version 5.8.2.

CVSS Base Scores

version 3.1