Cross-site Scripting (XSS) Affecting request-tracker5 package, versions <5.0.7+dfsg-4+deb13u1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.45% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-REQUESTTRACKER5-13659118
  • published23 Oct 2025
  • disclosed24 Oct 2025

Introduced: 23 Oct 2025

CVE-2025-9158  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:13 request-tracker5 to version 5.0.7+dfsg-4+deb13u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream request-tracker5 package and not the request-tracker5 package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

The Request Tracker software is vulnerable to a Stored XSS vulnerability in calendar invitation parsing feature, which displays invitation data without HTML sanitization. XSS vulnerability allows an attacker to send a specifically crafted e-mail enabling JavaScript code execution by displaying the ticket in the context of the logged-in user.

This vulnerability affects versions from 5.0.4 through 5.0.8 and from 6.0.0 through 6.0.1.