Integer Overflow or Wraparound Affecting rust-yamux package, versions *


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.47% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-RUSTYAMUX-15669486
  • published16 Mar 2026
  • disclosed13 Mar 2026

Introduced: 13 Mar 2026

CVE-2026-31814  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

There is no fixed version for Debian:13 rust-yamux.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rust-yamux package and not the rust-yamux package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Yamux is a stream multiplexer over reliable, ordered connections such as TCP/IP. From 0.13.0 to before 0.13.9, a specially crafted WindowUpdate can cause arithmetic overflow in send-window accounting, which triggers a panic in the connection state machine. This is remotely reachable over a normal network connection and does not require authentication. This vulnerability is fixed in 0.13.9.

CVSS Base Scores

version 3.1