Out-of-Bounds Affecting usbmuxd package, versions <1.0.7-2


Severity

Recommended
0.0
medium
0
10

Based on Debian security rating.

Threat Intelligence

EPSS
0.76% (51st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-USBMUXD-5698502
  • published6 Oct 2012
  • disclosed6 Oct 2012

Introduced: 6 Oct 2012

CVE-2012-0065  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:13 usbmuxd to version 1.0.7-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream usbmuxd package and not the usbmuxd package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

Heap-based buffer overflow in the receive_packet function in libusbmuxd/libusbmuxd.c in usbmuxd 1.0.5 through 1.0.7 allows physically proximate attackers to execute arbitrary code via a long SerialNumber field in a property list.

CVSS Base Scores

version 3.1