HTTP Request Smuggling Affecting varnish package, versions <7.7.0-3+deb13u1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.38% (32nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-VARNISH-17138903
  • published3 Jun 2026
  • disclosed3 Jun 2026

Introduced: 3 Jun 2026

CVE-2026-50052  (opens in a new tab)
CWE-444  (opens in a new tab)

How to fix?

Upgrade Debian:13 varnish to version 7.7.0-3+deb13u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream varnish package and not the varnish package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

In Vinyl Cache before 9.0.1 and Varnish Cache before 9.0.3, a deficiency in HTTP/2 request parsing can be exploited to launch a backend request desync attack (request smuggling), which in turn can be used for cache poisoning, authentication bypass, or possibly even information disclosure and manipulation. The attack vector only exists if HTTP/2 support is enabled by setting the feature parameter to contain +http2. HTTP/2 support is disabled by default.