Eval Injection Affecting vitrage package, versions <14.0.0-4+deb13u1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.85% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN13-VITRAGE-15363406
  • published27 Feb 2026
  • disclosed27 Feb 2026

Introduced: 27 Feb 2026

CVE-2026-28370  (opens in a new tab)
CWE-95  (opens in a new tab)

How to fix?

Upgrade Debian:13 vitrage to version 14.0.0-4+deb13u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vitrage package and not the vitrage package as distributed by Debian. See How to fix? for Debian:13 relevant fixed versions and status.

In the query parser in OpenStack Vitrage before 12.0.1, 13.0.0, 14.0.0, and 15.0.0, a user allowed to access the Vitrage API may trigger code execution on the Vitrage service host as the user the Vitrage service runs under. This may result in unauthorized access to the host and further compromise of the Vitrage service. All deployments exposing the Vitrage API are affected. This occurs in _create_query_function in vitrage/graph/query.py.