Security Features Affecting apparmor package, versions <3.0.12-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.03% (60th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-APPARMOR-11736030
  • published10 Aug 2025
  • disclosed22 Apr 2019

Introduced: 22 Apr 2019

CVE-2016-1585  (opens in a new tab)
CWE-254  (opens in a new tab)

How to fix?

Upgrade Debian:14 apparmor to version 3.0.12-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream apparmor package and not the apparmor package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

In all versions of AppArmor mount rules are accidentally widened when compiled.

CVSS Base Scores

version 3.1