Out-of-bounds Write Affecting bwa package, versions <0.7.17-3


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
2.91% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-BWA-11737088
  • published10 Aug 2025
  • disclosed29 Mar 2019

Introduced: 29 Mar 2019

CVE-2019-10269  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Debian:14 bwa to version 0.7.17-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream bwa package and not the bwa package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

BWA (aka Burrow-Wheeler Aligner) before 2019-01-23 has a stack-based buffer overflow in the bns_restore function in bntseq.c via a long sequence name in a .alt file.

CVSS Base Scores

version 3.1