Inefficient Regular Expression Complexity Affecting configobj package, versions <5.0.8-2


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.27% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-CONFIGOBJ-11739733
  • published10 Aug 2025
  • disclosed3 Apr 2023

Introduced: 3 Apr 2023

CVE-2023-26112  (opens in a new tab)
CWE-1333  (opens in a new tab)

How to fix?

Upgrade Debian:14 configobj to version 5.0.8-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream configobj package and not the configobj package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

All versions of the package configobj are vulnerable to Regular Expression Denial of Service (ReDoS) via the validate function, using (.+?)((.*)).

Note: This is only exploitable in the case of a developer, putting the offending value in a server side configuration file.

CVSS Base Scores

version 3.1