Numeric Errors Affecting exif package, versions <0.6.20-2


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
3.59% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-EXIF-11741117
  • published10 Aug 2025
  • disclosed13 Jul 2012

Introduced: 13 Jul 2012

CVE-2012-2845  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Debian:14 exif to version 0.6.20-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream exif package and not the exif package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Integer overflow in the jpeg_data_load_data function in jpeg-data.c in libjpeg in exif 0.6.20 allows remote attackers to cause a denial of service (buffer over-read and application crash) or obtain potentially sensitive information via a crafted JPEG file.

CVSS Base Scores

version 3.1