Encoding Error Affecting fence-agents package, versions <4.3.3-2


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
2.17% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-FENCEAGENTS-11741587
  • published10 Aug 2025
  • disclosed30 Jul 2019

Introduced: 30 Jul 2019

CVE-2019-10153  (opens in a new tab)
CWE-172  (opens in a new tab)

How to fix?

Upgrade Debian:14 fence-agents to version 4.3.3-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream fence-agents package and not the fence-agents package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A flaw was discovered in fence-agents, prior to version 4.3.4, where using non-ASCII characters in a guest VM's comment or other fields would cause fence_rhevm to exit with an exception. In cluster environments, this could lead to preventing automated recovery or otherwise denying service to clusters of which that VM is a member.

CVSS Base Scores

version 3.1