Improper Certificate Validation Affecting fence-agents package, versions <4.0.17-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.83% (53rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-FENCEAGENTS-11741666
  • published10 Aug 2025
  • disclosed2 Jan 2020

Introduced: 2 Jan 2020

CVE-2014-0104  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade Debian:14 fence-agents to version 4.0.17-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream fence-agents package and not the fence-agents package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

In fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py script which can potentially allow for man-in-the-middle attackers to spoof SSL servers via arbitrary SSL certificates.

CVSS Base Scores

version 3.1