Integer Overflow or Wraparound Affecting fluidsynth package, versions <2.5.6+dfsg-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.18% (8th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-FLUIDSYNTH-18292058
  • published24 Jul 2026
  • disclosed18 Sept 2026

Introduced: 24 Jul 2026

CVE-2026-61723  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Debian:14 fluidsynth to version 2.5.6+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream fluidsynth package and not the fluidsynth package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

FluidSynth is a software synthesizer based on the SoundFont 2 specifications. From 2.5.0 until 2.5.6, the native DLS parser validates ptbl chunks with the unsigned expression cues * 4 + cbsize without checking whether the multiplication and addition fit in 32 bits. A crafted DLS file can supply a large cues value that wraps the expression and passes the chunk-size check, causing poolcues.resize(cues) to request approximately four gigabytes and the parser to read billions of entries beyond the chunk boundary. The excessive allocation and invalid reads can cause denial of service. Builds with enable-native-dls set to OFF are not exposed. This issue is fixed in version 2.5.6.