Heap-based Buffer Overflow Affecting fluidsynth package, versions <2.5.6+dfsg-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.19% (8th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-FLUIDSYNTH-18292079
  • published24 Jul 2026
  • disclosed18 Sept 2026

Introduced: 24 Jul 2026

CVE-2026-61721  (opens in a new tab)
CWE-122  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Debian:14 fluidsynth to version 2.5.6+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream fluidsynth package and not the fluidsynth package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

FluidSynth is a software synthesizer based on the SoundFont 2 specifications. From 2.5.0 until 2.5.6, the native DLS loader assigns file-controlled wsmp.loop_start and wsmp.loop_length values to samples without calling fluid_sample_validate() or fluid_sample_sanitize_loop(). A crafted DLS file can place sample loop points beyond the sample buffer, causing out-of-bounds reads during audio rendering, undefined behavior, possible memory disclosure, and denial of service. Builds compiled with the CMake option enable-native-dls set to OFF do not expose the affected parser. This issue is fixed in version 2.5.6.