Out-of-bounds Read Affecting giflib package, versions <5.2.2-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
2.24% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-GIFLIB-11741348
  • published10 Aug 2025
  • disclosed21 Apr 2021

Introduced: 21 Apr 2021

CVE-2020-23922  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Debian:14 giflib to version 5.2.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream giflib package and not the giflib package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

An issue was discovered in giflib through 5.1.4. DumpScreen2RGB in gif2rgb.c has a heap-based buffer over-read.

CVSS Base Scores

version 3.1