CVE-2025-31344 Affecting giflib package, versions <6.1.3-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.26% (18th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-GIFLIB-11743969
  • published10 Aug 2025
  • disclosed14 Apr 2025

Introduced: 14 Apr 2025

CVE-2025-31344  (opens in a new tab)

How to fix?

Upgrade Debian:14 giflib to version 6.1.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream giflib package and not the giflib package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Heap-based Buffer Overflow vulnerability in openEuler giflib on Linux. This vulnerability is associated with program files gif2rgb.C.

This issue affects giflib: through 5.2.2.

CVSS Base Scores

version 3.1