Out-of-bounds Write Affecting hdf5 package, versions <1.14.5+repack-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.67% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-HDF5-11745454
  • published10 Aug 2025
  • disclosed9 Oct 2024

Introduced: 9 Oct 2024

CVE-2024-32608  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Debian:14 hdf5 to version 1.14.5+repack-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hdf5 package and not the hdf5 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

HDF5 library through 1.14.3 has memory corruption in H5A__close resulting in the corruption of the instruction pointer and causing denial of service or potential code execution.

CVSS Base Scores

version 3.1