Out-of-bounds Write Affecting indent package, versions <2.2.13-4


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.31% (23rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-INDENT-11746672
  • published10 Aug 2025
  • disclosed6 Feb 2024

Introduced: 6 Feb 2024

CVE-2024-0911  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Debian:14 indent to version 2.2.13-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream indent package and not the indent package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A flaw was found in indent, a program for formatting C code. This issue may allow an attacker to trick a user into processing a specially crafted file to trigger a heap-based buffer overflow, causing the application to crash.

CVSS Base Scores

version 3.1