CVE-2026-49839 Affecting jq package, versions <1.8.1-8


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.17% (6th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-JQ-17267776
  • published10 Jun 2026
  • disclosed25 Jun 2026

Introduced: 10 Jun 2026

CVE-2026-49839  (opens in a new tab)

How to fix?

Upgrade Debian:14 jq to version 1.8.1-8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream jq package and not the jq package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

jq is a command-line JSON processor. Prior to 1.8.2, jq --rawfile can turn a handled oversized-string error into invalid-state reuse and a real heap out-of-bounds write in assertion-disabled builds. When jv_load_file(raw=1) reads an attacker-controlled file, it repeatedly appends file chunks to the same jv string accumulator. Once jv_string_append_buf() returns jv_invalid_with_msg("String too long"), the raw-file loop does not stop. If the file contains at least one more byte, the next loop iteration appends a new chunk to an object that is already invalid. With assertions enabled this aborts in jvp_string_ptr(). With assertions disabled, the invalid object is interpreted as a string object and ASan reports heap-buffer-overflow. This vulnerability is fixed in 1.8.2.

CVSS Base Scores

version 3.1