Cross-site Scripting (XSS) Affecting ldap-account-manager package, versions <9.5.1-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.18% (7th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LDAPACCOUNTMANAGER-12795842
  • published17 Sept 2025
  • disclosed16 Sept 2025

Introduced: 16 Sep 2025

CVE-2025-58174  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:14 ldap-account-manager to version 9.5.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ldap-account-manager package and not the ldap-account-manager package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

LDAP Account Manager (LAM) is a webfrontend for managing entries stored in an LDAP directory. LAM before 9.3 allows stored cross-site scripting in the Profile section via the profile name field, which renders untrusted input as HTML and executes a supplied script (for example a script element). An authenticated user with permission to create or edit a profile can insert a script payload into the profile name and have it executed when the profile data is viewed in a browser. This issue is fixed in version 9.3. No known workarounds are mentioned.