CVE-2020-36843 Affecting libeddsa-java package, versions <0.3.0-2.1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.14% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIBEDDSAJAVA-11747941
  • published10 Aug 2025
  • disclosed13 Mar 2025

Introduced: 13 Mar 2025

CVE-2020-36843  (opens in a new tab)

How to fix?

Upgrade Debian:14 libeddsa-java to version 0.3.0-2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libeddsa-java package and not the libeddsa-java package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

The implementation of EdDSA in EdDSA-Java (aka ed25519-java) through 0.3.0 exhibits signature malleability and does not satisfy the SUF-CMA (Strong Existential Unforgeability under Chosen Message Attacks) property. This allows attackers to create new valid signatures different from previous signatures for a known message.

CVSS Base Scores

version 3.1