CVE-2026-104591 Affecting libosmocore package, versions <1.14.2-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.22% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIBOSMOCORE-21755100
  • published27 Oct 2026
  • disclosed26 Oct 2026

Introduced: 26 Oct 2026

NewCVE-2026-104591  (opens in a new tab)

How to fix?

Upgrade Debian:14 libosmocore to version 1.14.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libosmocore package and not the libosmocore package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

libosmocore through 1.14.1 contains a buffer overflow in osmo_iuup_compute_payload_crc() in src/gsm/iuup.c. This allows a remote attacker to cause a denial of service.