CVE-2026-6554 Affecting libpcap package, versions <1.10.7-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.44% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIBPCAP-19633462
  • published6 Sept 2026
  • disclosed5 Sept 2026

Introduced: 5 Sep 2026

CVE-2026-6554  (opens in a new tab)

How to fix?

Upgrade Debian:14 libpcap to version 1.10.7-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpcap package and not the libpcap package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

libpcap BPF interpreter treats the offset in the 'ja L' BPF instruction as a signed integer to implement looping via backward jumps, but it does not limit the number of loop iterations. A crafted filter program or the 'protochain' primitive used on a crafted network packet can cause the interpreter to loop infinitely.

CVSS Base Scores

version 3.1