CVE-2026-18313 Affecting libpcap package, versions <1.10.7-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.23% (12th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LIBPCAP-19633465
  • published6 Sept 2026
  • disclosed5 Sept 2026

Introduced: 5 Sep 2026

CVE-2026-18313  (opens in a new tab)

How to fix?

Upgrade Debian:14 libpcap to version 1.10.7-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpcap package and not the libpcap package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

rpcapd can allocate up to 65536 bytes per each RPCAP_MSG_UPDATEFILTER_REQ or RPCAP_MSG_STARTCAP_REQ message received from the client, but it never frees the memory, so it leaks memory even under normal use. A malicious client can cause the server to leak memory substantially faster.

CVSS Base Scores

version 3.1