Improper Input Validation Affecting lynx package, versions <2.8.5-2sarge1.2


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
3.75% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-LYNX-11760310
  • published10 Aug 2025
  • disclosed18 Oct 2004

Introduced: 18 Oct 2004

CVE-2004-1617  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:14 lynx to version 2.8.5-2sarge1.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lynx package and not the lynx package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Lynx, lynx-ssl, and lynx-cur before 2.8.6dev.8 allow remote attackers to cause a denial of service (infinite loop) via a web page or HTML email that contains invalid HTML including (1) a TEXTAREA tag with a large COLS value and (2) a large tag name in an element that is not terminated, as demonstrated by mangleme. NOTE: a followup suggests that the relevant trigger for this issue is the large COLS value.

CVSS Base Scores

version 3.1