Improper Input Validation The advisory has been revoked - it doesn't affect any version of package matrix-synapse  (opens in a new tab)


Threat Intelligence

EPSS
1.23% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-MATRIXSYNAPSE-13601351
  • published17 Oct 2025
  • disclosed27 Mar 2025

Introduced: 27 Mar 2025

CVE-2025-30355  (opens in a new tab)
CWE-20  (opens in a new tab)

Amendment

The Debian security team deemed this advisory irrelevant for Debian:14.

NVD Description

Note: Versions mentioned in the description apply only to the upstream matrix-synapse package and not the matrix-synapse package as distributed by Debian.

Synapse is an open source Matrix homeserver implementation. A malicious server can craft events which, when received, prevent Synapse version up to 1.127.0 from federating with other servers. The vulnerability has been exploited in the wild and has been fixed in Synapse v1.127.1. No known workarounds are available.