Access Restriction Bypass Affecting multipath-tools package, versions <0.4.8-15


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.49% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-MULTIPATHTOOLS-11761232
  • published10 Aug 2025
  • disclosed30 Mar 2009

Introduced: 30 Mar 2009

CVE-2009-0115  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Debian:14 multipath-tools to version 0.4.8-15 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream multipath-tools package and not the multipath-tools package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

The Device Mapper multipathing driver (aka multipath-tools or device-mapper-multipath) 0.4.8, as used in SUSE openSUSE, SUSE Linux Enterprise Server (SLES), Fedora, and possibly other operating systems, uses world-writable permissions for the socket file (aka /var/run/multipathd.sock), which allows local users to send arbitrary commands to the multipath daemon.

CVSS Base Scores

version 3.1