CVE-2025-55780 Affecting mupdf package, versions <1.27.0+ds1-2


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.43% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-MUPDF-13045562
  • published25 Sept 2025
  • disclosed23 Sept 2025

Introduced: 23 Sep 2025

CVE-2025-55780  (opens in a new tab)

How to fix?

Upgrade Debian:14 mupdf to version 1.27.0+ds1-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mupdf package and not the mupdf package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A null pointer dereference occurs in the function break_word_for_overflow_wrap() in MuPDF 1.26.4 when rendering a malformed EPUB document. Specifically, the function calls fz_html_split_flow() to split a FLOW_WORD node, but does not check if node->next is valid before accessing node->next->overflow_wrap, resulting in a crash if the split fails or returns a partial node chain.