Integer Overflow or Wraparound Affecting newlib package, versions <4.4.0.20231231-2


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.76% (51st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-NEWLIB-11761703
  • published10 Aug 2025
  • disclosed20 Aug 2024

Introduced: 20 Aug 2024

CVE-2024-30949  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Debian:14 newlib to version 4.4.0.20231231-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream newlib package and not the newlib package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

An issue in newlib v.4.3.0 allows an attacker to execute arbitrary code via the time unit scaling in the _gettimeofday function.

CVSS Base Scores

version 3.1