Numeric Errors Affecting nvi package, versions <1.81.6-13


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
8.88% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-NVI-11762421
  • published10 Aug 2025
  • disclosed30 Mar 2015

Introduced: 30 Mar 2015

CVE-2015-2305  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Debian:14 nvi to version 1.81.6-13 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nvi package and not the nvi package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Integer overflow in the regcomp implementation in the Henry Spencer BSD regex library (aka rxspencer) alpha3.8.g5 on 32-bit platforms, as used in NetBSD through 6.1.5 and other products, might allow context-dependent attackers to execute arbitrary code via a large regular expression that leads to a heap-based buffer overflow.

CVSS Base Scores

version 3.1