CVE-2025-31335 Affecting opensaml package, versions <3.3.1-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.25% (16th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-OPENSAML-11763410
  • published10 Aug 2025
  • disclosed28 Mar 2025

Introduced: 28 Mar 2025

CVE-2025-31335  (opens in a new tab)

How to fix?

Upgrade Debian:14 opensaml to version 3.3.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opensaml package and not the opensaml package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

The OpenSAML C++ library before 3.3.1 allows forging of signed SAML messages via parameter manipulation (when using SAML bindings that rely on non-XML signatures).

CVSS Base Scores

version 3.1