CVE-2026-104593 Affecting osmo-msc package, versions <1.16.0+dfsg1-2


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.22% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-OSMOMSC-21755529
  • published27 Oct 2026
  • disclosed26 Oct 2026

Introduced: 26 Oct 2026

NewCVE-2026-104593  (opens in a new tab)

How to fix?

Upgrade Debian:14 osmo-msc to version 1.16.0+dfsg1-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream osmo-msc package and not the osmo-msc package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

osmo-msc through 1.15.0 contains a stack-based buffer overflow in decode_mme_name() in src/libmsc/sgs_iface.c. This allows a remote attacker to cause a denial of service.