CVE-2026-19816 Affecting packagekit package, versions <1.4.0-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
0.14% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PACKAGEKIT-19667741
  • published10 Sept 2026
  • disclosed14 Sept 2026

Introduced: 10 Sep 2026

CVE-2026-19816  (opens in a new tab)

How to fix?

Upgrade Debian:14 packagekit to version 1.4.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream packagekit package and not the packagekit package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

A flaw was found in PackageKit. PackageKit skips the polkit authorization check for transactions carrying the SIMULATE (dry-run) flag. In the dnf5 backend, the RepoRemove handler ignores that contract and always executes the real transaction because its guard is written as (role == REPO_REMOVE || !SIMULATE), which is always true for RepoRemove. An unprivileged local user can therefore perform a genuine package uninstall while claiming to simulate. This vulnerability only affects systems using PackageKit with the dnf5 backend.

CVSS Base Scores

version 3.1