Improper Neutralization Affecting php-league-flysystem package, versions <3.36.0-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.34% (25th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-PHPLEAGUEFLYSYSTEM-20336353
  • published30 Sept 2026
  • disclosed29 Sept 2026

Introduced: 29 Sep 2026

NewCVE-2026-102601  (opens in a new tab)
CWE-150  (opens in a new tab)

How to fix?

Upgrade Debian:14 php-league-flysystem to version 3.36.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-league-flysystem package and not the php-league-flysystem package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Flysystem is an open source file storage library for PHP. Prior to 3.35.3, the default WhitespacePathNormalizer in src/WhitespacePathNormalizer.php used by Filesystem across adapters calls preg_match with the u modifier and treats both false and 0 as falsy. A path containing malformed UTF-8 causes PCRE to return false, so paths that also contain control characters bypass CorruptedPathDetected::forPath() in normalizePath(). Filesystem::write() can store such names and Filesystem::listContents() can return the raw ANSI escape sequences, allowing hidden or spoofed terminal file listings when an administrator displays them. This issue is fixed in version 3.35.3.