Insufficiently Protected Credentials Affecting requests package, versions <2.20.0-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
6.93% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-REQUESTS-11766947
  • published10 Aug 2025
  • disclosed9 Oct 2018

Introduced: 9 Oct 2018

CVE-2018-18074  (opens in a new tab)
CWE-522  (opens in a new tab)

How to fix?

Upgrade Debian:14 requests to version 2.20.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream requests package and not the requests package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

The Requests package before 2.20.0 for Python sends an HTTP Authorization header to an http URI upon receiving a same-hostname https-to-http redirect, which makes it easier for remote attackers to discover credentials by sniffing the network.

CVSS Base Scores

version 3.1