Use of a Broken or Risky Cryptographic Algorithm Affecting request-tracker5 package, versions <5.0.7+dfsg-3


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.19% (8th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-REQUESTTRACKER5-11766588
  • published10 Aug 2025
  • disclosed5 May 2025

Introduced: 5 May 2025

CVE-2025-2545  (opens in a new tab)
CWE-327  (opens in a new tab)

How to fix?

Upgrade Debian:14 request-tracker5 to version 5.0.7+dfsg-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream request-tracker5 package and not the request-tracker5 package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

Vulnerability in Best Practical Solutions, LLC's Request Tracker prior to v5.0.8, where the Triple DES (3DES) cryptographic algorithm is used to protect emails sent with S/MIME encryption. Triple DES is considered obsolete and insecure due to its susceptibility to birthday attacks, which could compromise the confidentiality of encrypted messages.