Improper Enforcement of Message or Data Structure The advisory has been revoked - it doesn't affect any version of package sogo  (opens in a new tab)


Threat Intelligence

EPSS
0.61% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-SOGO-11767940
  • published10 Aug 2025
  • disclosed16 Dec 2022

Introduced: 16 Dec 2022

CVE-2022-4556  (opens in a new tab)
CWE-707  (opens in a new tab)

Amendment

The Debian security team deemed this advisory irrelevant for Debian:14.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sogo package and not the sogo package as distributed by Debian.

A vulnerability was found in Alinto SOGo up to 5.7.1 and classified as problematic. Affected by this issue is the function _migrateMailIdentities of the file SoObjects/SOGo/SOGoUserDefaults.m of the component Identity Handler. The manipulation of the argument fullName leads to cross site scripting. The attack may be launched remotely. Upgrading to version 5.8.0 is able to address this issue. The name of the patch is efac49ae91a4a325df9931e78e543f707a0f8e5e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215960.