CVE-2024-56520 Affecting tcpdf package, versions <6.8.0+dfsg-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.56% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-TCPDF-11769229
  • published10 Aug 2025
  • disclosed27 Dec 2024

Introduced: 27 Dec 2024

CVE-2024-56520  (opens in a new tab)

How to fix?

Upgrade Debian:14 tcpdf to version 6.8.0+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tcpdf package and not the tcpdf package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

An issue was discovered in tc-lib-pdf-font before 2.6.4, as used in TCPDF before 6.8.0 and other products. Fonts are mishandled, e.g., FontBBox for Type 1 and TrueType fonts is misparsed.