CVE-2024-34062 Affecting tqdm package, versions <4.66.4-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.44% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-TQDM-11771022
  • published10 Aug 2025
  • disclosed3 May 2024

Introduced: 3 May 2024

CVE-2024-34062  (opens in a new tab)

How to fix?

Upgrade Debian:14 tqdm to version 4.66.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tqdm package and not the tqdm package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

tqdm is an open source progress bar for Python and CLI. Any optional non-boolean CLI arguments (e.g. --delim, --buf-size, --manpath) are passed through python's eval, allowing arbitrary code execution. This issue is only locally exploitable and had been addressed in release version 4.66.3. All users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS Base Scores

version 3.1