Integer Overflow or Wraparound Affecting uclibc package, versions <1.0.54-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.72% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-UCLIBC-11771006
  • published10 Aug 2025
  • disclosed3 May 2022

Introduced: 3 May 2022

CVE-2021-27419  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Debian:14 uclibc to version 1.0.54-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream uclibc package and not the uclibc package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

uClibc-ng versions prior to 1.0.37 are vulnerable to integer wrap-around in functions malloc-simple. This improper memory assignment can lead to arbitrary memory allocation, resulting in unexpected behavior such as a crash or a remote code injection/execution.

CVSS Base Scores

version 3.1