CVE-2026-35501 Affecting unbound package, versions <1.26.2-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.11% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-UNBOUND-21404852
  • published22 Oct 2026
  • disclosed21 Oct 2026

Introduced: 21 Oct 2026

NewCVE-2026-35501  (opens in a new tab)

How to fix?

Upgrade Debian:14 unbound to version 1.26.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream unbound package and not the unbound package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

When NLnet Labs Unbound 1.0.1 up to and including version 1.26.1 is configured with both a root trust anchor and an additional 'trust-anchor:' for an island-of-security zone whose parent is provably insecure under the root chain, a malicious actor with a forged NSEC reply with the SOA bit cleared can trick Unbound to treat the configured trust island as insecure. This happens because the DNSSEC validator in Unbound accepts and caches the NSEC insecure response bypassing the RRSIG validation that the validator was supposed to do. The acceptance of the NSEC record at the trust anchor apex was allowed due to and old fix for type DS and NSEC queries from clients when trust anchor for that name existed.