CVE-2026-96405 Affecting unbound package, versions <1.26.2-1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.25% (17th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-UNBOUND-21404856
  • published22 Oct 2026
  • disclosed21 Oct 2026

Introduced: 21 Oct 2026

NewCVE-2026-96405  (opens in a new tab)

How to fix?

Upgrade Debian:14 unbound to version 1.26.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream unbound package and not the unbound package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

NLnet Labs Unbound up to and including version 1.26.1 limits compression-pointer traversal for each individual domain-name operation but has no aggregate inbound decompression-work budget. Many chained compression pointers in a message results in a lot of CPU usage following them. A malicious actor with recursive-query access and control of an ordinarily delegated authority that serves specially crafted replies can exploit the vulnerability and degrade Unbound's general performance.