CVE-2004-2259 Affecting vsftpd package, versions <2.0.1-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
2.07% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN14-VSFTPD-11771727
  • published10 Aug 2025
  • disclosed31 Dec 2004

Introduced: 31 Dec 2004

CVE-2004-2259  (opens in a new tab)

How to fix?

Upgrade Debian:14 vsftpd to version 2.0.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vsftpd package and not the vsftpd package as distributed by Debian. See How to fix? for Debian:14 relevant fixed versions and status.

vsftpd before 1.2.2, when under heavy load, allows attackers to cause a denial of service (crash) via a SIGCHLD signal during a malloc or free call, which is not re-entrant.

CVSS Base Scores

version 3.1