Cross-site Scripting (XSS) Affecting libjs-swfupload package, versions <2.2.0.1+ds1-2


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
9.41% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-LIBJSSWFUPLOAD-268688
  • published19 Jul 2013
  • disclosed19 Jul 2013

Introduced: 19 Jul 2013

CVE-2012-3414  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:9 libjs-swfupload to version 2.2.0.1+ds1-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libjs-swfupload package and not the libjs-swfupload package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

Cross-site scripting (XSS) vulnerability in swfupload.swf in SWFUpload 2.2.0.1 and earlier, as used in WordPress before 3.3.2, TinyMCE Image Manager 1.1, and other products, allows remote attackers to inject arbitrary web script or HTML via the movieName parameter, related to the "ExternalInterface.call" function.

CVSS Base Scores

version 3.1