Information Exposure Affecting libsocialweb package, versions <0.25.20-3.1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.82% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-LIBSOCIALWEB-272596
  • published22 Oct 2012
  • disclosed22 Oct 2012

Introduced: 22 Oct 2012

CVE-2012-4511  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Debian:9 libsocialweb to version 0.25.20-3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsocialweb package and not the libsocialweb package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

services/flickr/flickr.c in libsocialweb before 0.25.21 automatically connects to Flickr when no Flickr account is set, which might allow remote attackers to obtain sensitive information via a man-in-the-middle (MITM) attack.

CVSS Base Scores

version 3.1