Out-of-Bounds Affecting mapserver package, versions <5.4.2-1


Severity

Recommended
medium

Based on Debian security rating.

Threat Intelligence

EPSS
5.95% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-MAPSERVER-281481
  • published23 Oct 2009
  • disclosed23 Oct 2009

Introduced: 23 Oct 2009

CVE-2009-2281  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:9 mapserver to version 5.4.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mapserver package and not the mapserver package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

Multiple heap-based buffer underflows in the readPostBody function in cgiutil.c in mapserv in MapServer 4.x through 4.10.4 and 5.x before 5.4.2 allow remote attackers to execute arbitrary code via (1) a crafted Content-Length HTTP header or (2) a large HTTP request, related to an integer overflow that triggers a heap-based buffer overflow. NOTE: this issue reportedly exists because of an incomplete fix for CVE-2009-0840.

CVSS Base Scores

version 3.1