SQL Injection Affecting mapserver package, versions <5.6.4-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.31% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-MAPSERVER-281517
  • published22 Sept 2010
  • disclosed22 Sept 2010

Introduced: 22 Sep 2010

CVE-2010-3484  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade Debian:9 mapserver to version 5.6.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mapserver package and not the mapserver package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

SQL injection vulnerability in common.php in LightNEasy 3.2.1 allows remote attackers to execute arbitrary SQL commands via the handle parameter to LightNEasy.php, a different vector than CVE-2008-6593.

CVSS Base Scores

version 3.1