Race Condition Affecting pulseaudio package, versions <0.9.15-4.1


Severity

Recommended
0.0
high
0
10

Based on Debian security rating.

Threat Intelligence

EPSS
0.74% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-PULSEAUDIO-406426
  • published17 Jul 2009
  • disclosed17 Jul 2009

Introduced: 17 Jul 2009

CVE-2009-1894  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade Debian:9 pulseaudio to version 0.9.15-4.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pulseaudio package and not the pulseaudio package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

Race condition in PulseAudio 0.9.9, 0.9.10, and 0.9.14 allows local users to gain privileges via vectors involving creation of a hard link, related to the application setting LD_BIND_NOW to 1, and then calling execv on the target of the /proc/self/exe symlink.

CVSS Base Scores

version 3.1