Out-of-Bounds Affecting python2.7 package, versions <2.7.6-6


low

Snyk CVSS

    Exploit Maturity Mature
    Attack Complexity Low
NVD  high
Red Hat  medium
SUSE  high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN9-PYTHON27-306518
  • published 1 Mar 2014
  • disclosed 1 Mar 2014

How to fix?

Upgrade Debian:9 python2.7 to version 2.7.6-6 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream python2.7 package. See How to fix? for Debian:9 relevant versions.

Buffer overflow in the socket.recvfrom_into function in Modules/socketmodule.c in Python 2.5 before 2.7.7, 3.x before 3.3.4, and 3.4.x before 3.4rc1 allows remote attackers to execute arbitrary code via a crafted string.