Access Restriction Bypass Affecting python2.7 package, versions <2.7.3~rc2-2


0.0
low

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
NVD
CVSS v3 N/A  low
Red Hat
CVSS v3 N/A  low
Expand this section
SUSE
3.3 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN9-PYTHON27-306567
  • published 27 Aug 2012
  • disclosed 27 Aug 2012

How to fix?

Upgrade Debian:9 python2.7 to version 2.7.3~rc2-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python2.7 package and not the python2.7 package as distributed by Debian:9. See How to fix? for Debian:9 relevant fixed versions and status.

Python 2.6 through 3.2 creates ~/.pypirc with world-readable permissions before changing them after data has been written, which introduces a race condition that allows local users to obtain a username and password by reading this file.